New Update! » June 15, 2023

Incident Report for SndeTeam

Resolved

The new update has been released. - The announced RDR2 wallpapers will come soon - More about it on #2 of this status report.
Posted Jun 16, 2023 - 22:26 CEST

Update

We're happy to announce that the update will be released as scheduled. However, we encountered some issues while adding the highly anticipated RDR2: West Elizabeth wallpapers that were previously announced. We apologize for the inconvenience caused and assure you that we are working diligently to resolve the problem. Once the issue is fixed, we will release another update to include the promised wallpapers.

We appreciate your understanding and patience. Thank you!
Posted Jun 15, 2023 - 00:07 CEST

Investigating

The new update is now being prepared for release! - In the meantime, there may be minor performance problems as a lot of content is being prepared. - Also for upcoming updates.

» https://www.sndeteam.com
Report an error → http://help.sndeteam.eu
Posted Jun 11, 2023 - 21:57 CEST