Update April #2

Incident Report for SndeTeam

Resolved

The update that was scheduled for April 10, 2023 was released today. The reason is that we fixed many critical bugs that came with the official April 2023 update.
Posted Apr 07, 2023 - 16:29 CEST