April Update:

Incident Report for SndeTeam

Resolved

The April update is now completely online! Changelog you can find here:
» https://www.sndeteam.de/news/09

- On 10 April 2023 another update will come which will extend the accessibility of our website. More information will follow.
Posted Apr 06, 2023 - 22:19 CEST

Investigating

The new update is finally on its way!

More information can be found on our social media platforms (@SndeTeam) The changelog will follow on update day. - There will be 2 updates in April.
Posted Mar 29, 2023 - 02:41 CEST